Bug 5014 - Login in Web Access in Firefox creates two items in the browser history
Summary: Login in Web Access in Firefox creates two items in the browser history
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Web Access (show other bugs)
Version: trunk
Hardware: PC Unknown
: P2 Normal
Target Milestone: 4.13.0
Assignee: Pierre Ossman
URL:
Keywords: nikle_tester, prosaic
Depends on:
Blocks:
 
Reported: 2014-03-05 15:56 CET by Samuel Mannehed
Modified: 2020-10-12 13:46 CEST (History)
1 user (show)

See Also:
Acceptance Criteria:


Attachments

Description Samuel Mannehed cendio 2014-03-05 15:56:48 CET
After login in the HTML5 client you have three items in the Firefox browser history. Two which both lead to the login page on the master server and one which is the actual client on the agent. In Chrome, Safari and Internet Explorer only one item for the login page is created in the history, this is the desired behavior.
The two items seen in Firefox are likely caused by the two POST which happen during the login process.

Fixing this would require architectural changes. Maybe use WebSockets instead of the first POST?
Comment 1 Pierre Ossman cendio 2020-09-25 14:42:50 CEST
This seems to work fine in current versions of Firefox (tested with 80.0), where I now only get a single history step from the login window to the session.

The redirection page is a bit oddly handled in the code though, so I'll use this bug to do a bit of a cleanup.
Comment 3 Pierre Ossman cendio 2020-09-28 13:08:06 CEST
All done and redirection still works fine.
Comment 4 Niko Lehto cendio 2020-10-12 13:46:39 CEST
Redirection works fine, no duplicate entries in history either. Tested on Firefox 81.

Note You need to log in before you can comment on or make changes to this bug.