www.cendio.com
Bug 5240 - services restarted by tlwebadm get wrong SELinux context
: services restarted by tlwebadm get wrong SELinux context
Status: CLOSED FIXED
: ThinLinc
Web Administration
: trunk
: PC Unknown
: P2 Normal
: 4.3.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-09-03 12:45 by
Modified: 2014-10-06 16:25 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-09-03 12:45:00
Before:

> system_u:system_r:thinlinc_agent_t:s0 1486 ?   Ss     0:00 python-thinlinc /opt/thinlinc/sbin/vsmagent
> system_u:system_r:thinlinc_master_t:s0 1570 ?  Ss     0:00 python-thinlinc /opt/thinlinc/sbin/vsmserver

After:

> system_u:system_r:thinlinc_webadm_t:s0 1914 ?  Ss     0:00 python-thinlinc /opt/thinlinc/sbin/vsmserver
> system_u:system_r:thinlinc_webadm_t:s0 1971 ?  Ss     0:00 python-thinlinc /opt/thinlinc/sbin/vsmagent

As you can see, the services inherit tlwebadm's context. Not sure why as
tlwebadm is unconfined.

This is a regression (of sorts) caused by commit r28234 in bug 4780.
------- Comment #1 From cendio 2014-09-03 16:22:54 -------
Fixed in r29320.
------- Comment #2 From cendio 2014-09-24 12:11:25 -------
Tested using build 4497 on RHEL7, works as expected.