www.cendio.com
Bug 5283 - all thinlocal jobs are sent as raw with recent cups
: all thinlocal jobs are sent as raw with recent cups
Status: CLOSED FIXED
: ThinLinc
Printing
: trunk
: PC Unknown
: P2 Normal
: 4.3.0
Assigned To:
:
:
:
: 4939
  Show dependency treegraph
 
Reported: 2014-10-03 13:36 by
Modified: 2014-10-08 10:13 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-10-03 13:36:40
For some reason all jobs sent via thinlocal are sent as
"application/octet-stream" (i.e. raw) when the distribution is modern enough.
We've seen this on Fedora 20 and RHEL 7. It does not happen on older systems.
Best guess right now is that the change happened in CUPS 1.6.

The cause it not yet fully known, but it seems like they've changed the
behaviour of FINAL_CONTENT_TYPE.
------- Comment #2 From cendio 2014-10-03 14:40:48 -------
Checked the environment and arguments given to thinlocal. The correct content
type is nowhere to be found. Filed a bug upstream:

https://www.cups.org/str.php?L4494
------- Comment #3 From cendio 2014-10-03 17:09:51 -------
God dammit. Turns out to be Red Hat that explicitly breaks their CUPS in order
to work around problems in a PPD:

https://bugzilla.redhat.com/show_bug.cgi?id=1010580
------- Comment #4 From cendio 2014-10-03 17:16:19 -------
Filed new bugs with Red Hat:

https://bugzilla.redhat.com/show_bug.cgi?id=1149244
https://bugzilla.redhat.com/show_bug.cgi?id=1149245
------- Comment #5 From cendio 2014-10-07 13:23:17 -------
Platform specific note added in r29469.

That's all we'll do for now. Will continue to monitor the upstream bugs though
for progress.
------- Comment #6 From cendio 2014-10-08 10:13:35 -------
(In reply to comment #5)
> Platform specific note added in r29469.
> 
> That's all we'll do for now. Will continue to monitor the upstream bugs though
> for progress.

Platform specific note looks good.