www.cendio.com
Bug 5326 - constants TLCONTROL and SCANSCRIPT in tlclient doesn't use tlprefix
: constants TLCONTROL and SCANSCRIPT in tlclient doesn't use tlprefix
Status: CLOSED FIXED
: ThinLinc
Client
: trunk
: PC Unknown
: P2 Normal
: 4.4.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2014-10-27 09:50 by
Modified: 2015-05-22 15:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2014-10-27 09:50:57
We can't hardcode the paths to "/opt/thinlinc". 

This bug causes for example that the control panel isn't displayed from
vncviewer on thinstation.
------- Comment #2 From cendio 2014-11-04 14:53:25 -------
r29566.
------- Comment #3 From cendio 2015-04-22 14:39:33 -------
Works fine - tlclient tries to find local-scan and tlcontrol relative to where
it's launched from.

> derfian@aperture:/home/[...]/tl-4.3.0post-4732-client-linux-dynamic-x86_64 $ strace -e trace=file -f bin/tlclient -c 2>&1 | grep -i tlcontrol
> [pid 20633] access("/home/[...]/tl-4.3.0post-4732-client-linux-dynamic-x86_64/lib/tlclient/tlcontrol", X_OK) = 0

> derfian@aperture:/home/[...]/tl-4.3.0post-4732-client-linux-dynamic-x86_64 $ strace -e trace=file -f bin/tlclient -c 2>&1 | grep -i local-scan
> [pid 22404] access("/home/[...]/tl-4.3.0post-4732-client-linux-dynamic-x86_64/lib/tlclient/local-scan", X_OK) = -1 ENOENT (No such file or directory)
------- Comment #4 From cendio 2015-05-22 15:24:28 -------
*** Bug 3831 has been marked as a duplicate of this bug. ***