www.cendio.com
Bug 5450 - Adapt client to 64-bit OS X 10.6 platform
: Adapt client to 64-bit OS X 10.6 platform
Status: CLOSED DUPLICATE of bug 5257
: ThinLinc
Client
: trunk
: PC Unknown
: P2 Normal
: 4.4.0
Assigned To:
:
:
: 5257
:
  Show dependency treegraph
 
Reported: 2015-02-26 11:00 by
Modified: 2015-03-11 11:19 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-02-26 11:00:26
On bug 5257, we created the new "osx64" build environment. This is the
product/client side of that bug. We need to adapt the client to build and run
on this platform.
------- Comment #1 From cendio 2015-02-26 13:16:23 -------
With 30048, a 64 bit client builds and runs, although without printing dialog
or pcsctun support.
------- Comment #2 From cendio 2015-02-26 16:19:55 -------
(In reply to comment #1)
> With 30048, a 64 bit client builds and runs, although without printing dialog
> or pcsctun support.

pcsctun fixed in 30051. Smart card authentication fails with:

2015-02-26T16:08:15: Unable to load PKCS#11 module '/Volumes/ThinLinc
Client/ThinLinc Client.app/Contents/lib/tlclient/opensc-pkcs11.dylib':
2015-02-26T16:08:15: dlopen(/Volumes/ThinLinc Client/ThinLinc
Client.app/Contents/lib/tlclient/opensc-pkcs11.dylib, 1): Library not loaded:
/usr/x86_64-apple-darwin10/sys-root/usr/lib/libcrypto.1.0.0.dylib
2015-02-26T16:08:15:   Referenced from: /Volumes/ThinLinc Client/ThinLinc
Client.app/Contents/lib/tlclient/opensc-pkcs11.dylib
2015-02-26T16:08:15:   Reason: image not found
------- Comment #3 From cendio 2015-02-26 16:43:14 -------
(In reply to comment #2)
> (In reply to comment #1)
> > With 30048, a 64 bit client builds and runs, although without printing dialog
> > or pcsctun support.
> 
> pcsctun fixed in 30051. Smart card authentication fails with:
> 
> 2015-02-26T16:08:15: Unable to load PKCS#11 module '/Volumes/ThinLinc
> Client/ThinLinc Client.app/Contents/lib/tlclient/opensc-pkcs11.dylib':
> 2015-02-26T16:08:15: dlopen(/Volumes/ThinLinc Client/ThinLinc
> Client.app/Contents/lib/tlclient/opensc-pkcs11.dylib, 1): Library not loaded:
> /usr/x86_64-apple-darwin10/sys-root/usr/lib/libcrypto.1.0.0.dylib
> 2015-02-26T16:08:15:   Referenced from: /Volumes/ThinLinc Client/ThinLinc
> Client.app/Contents/lib/tlclient/opensc-pkcs11.dylib
> 2015-02-26T16:08:15:   Reason: image not found

Regression, bug 5293. Fixed.
------- Comment #4 From cendio 2015-03-03 09:49:59 -------
(In reply to comment #0)
> On bug 5257, we created the new "osx64" build environment. This is the
> product/client side of that bug. We need to adapt the client to build and run
> on this platform.

Change of heart. Both the build system and product/client will be handled on
bug 5257.

*** This bug has been marked as a duplicate of bug 5257 ***