www.cendio.com
Bug 5743 - sound non-functional with srb channel on client (PulseAudio 7.0+)
: sound non-functional with srb channel on client (PulseAudio 7.0+)
Status: CLOSED FIXED
: ThinLinc
Sound
: pre-1.0
: PC Unknown
: P2 Normal
: 4.6.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-12-04 15:26 by
Modified: 2016-04-12 12:50 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-12-04 15:26:08
With -d5 I get this in the log:

> 2015-12-04T15:18:58: pulseaudio[E]: D: [tunnel-sink] context.c: Protocol version: remote 30, local 30
> 2015-12-04T15:18:58: pulseaudio[E]: D: [tunnel-sink] context.c: Negotiated SHM: yes
> 2015-12-04T15:18:58: pulseaudio[E]: D: [tunnel-sink] module-tunnel-sink-new.c: Context failed: Protocol error.

No idea why yet or exactly which combinations that fail to work.
------- Comment #1 From cendio 2015-12-04 15:43:34 -------
The 4.4.0 client with the older PulseAudio works:

> 2015-12-04T15:42:23: pulseaudio[E]: D: [pulseaudio] protocol-native.c: Protocol version: remote 30, local 28
> 2015-12-04T15:42:23: pulseaudio[E]: D: [pulseaudio] protocol-native.c: SHM possible: no
> 2015-12-04T15:42:23: pulseaudio[E]: D: [pulseaudio] protocol-native.c: Negotiated SHM: no
------- Comment #2 From cendio 2015-12-07 10:04:54 -------
The problem is the srb channel which is completely non-functional in our
PulseAudio. Unfortunately it still tries to use it if the local PulseAudio
supports it, but then of course fails. This affects any distribution which has
this feature turned on, which is PulseAudio 7.0 or newer, or 6.0 with extra
configuration.
------- Comment #3 From cendio 2015-12-07 16:04:56 -------
Upstream bug:

https://bugs.freedesktop.org/show_bug.cgi?id=93285

It doesn't affect the PulseAudio server in the sessions as it already has
correct handling of failing to start the SRB channel.
------- Comment #4 From cendio 2015-12-07 16:10:43 -------
Added bug 5746 about properly supporting the SRB channel.
------- Comment #6 From cendio 2015-12-10 08:27:06 -------
Verified that i had the problem using old client build on fedora 23. Upgraded
to client build 4969 and all works as expected.
------- Comment #7 From cendio 2015-12-10 08:37:16 -------
Need to test regression using old pulseaudio on the client side.
------- Comment #8 From cendio 2015-12-10 08:37:16 -------
Need to test regression using old pulseaudio on the client side.
------- Comment #9 From cendio 2015-12-10 14:36:21 -------
(In reply to comment #8)
> Need to test regression using old pulseaudio on the client side.

Tested using thinlinc build 4969 on eLux RP (Pulseaudio V6.0).

Sound works as expected.