www.cendio.com
Bug 5753 - Gradients show banding with rdesktop
: Gradients show banding with rdesktop
Status: CLOSED FIXED
: ThinLinc
rdesktop
: trunk
: PC Unknown
: P2 Normal
: 4.9.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-12-15 13:07 by
Modified: 2018-02-27 09:59 (History)
Acceptance Criteria:


Attachments
Sample gradient with banding from WordPad (108.65 KB, image/png)
2015-12-15 13:07, Karl Mikaelsson
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-12-15 13:07:36
Created an attachment (id=661) [details]
Sample gradient with banding from WordPad

Windows 2012 R2, CentOS 7 x86_64, ThinLinc-4.5.0post-4970

How to reproduce:

 - Connect to Windows server with tl-run-rdesktop.
 - Start WordPad.
 - Zoom out until you see the background gradient on each side of the empty
document.

The gradient should be smooth, but it's showing clear banding, which would
indicate a bit depth problem. The attached image shows the problem clearly.
This warning from rdesktop is most likely the problem:

> WARNING: Remote desktop does not support colour depth 24; falling back to 16

Pierre mentioned something about Windows moving to 32-bit color instead of 24.
------- Comment #1 From cendio 2017-10-18 12:57:22 -------
https://github.com/rdesktop/rdesktop/pull/177
------- Comment #3 From cendio 2017-12-12 18:44:22 -------
Vendor drop r32951 introduces support for 32-bit color.
------- Comment #4 From cendio 2017-12-29 14:28:12 -------
I can't reproduce the original problem with rdesktop from 4.5.0, 4.7.0 and
4.8.0 (and obviously not 4.8.0post). Connecting to the Windows Server 2012 lab
environment.
------- Comment #5 From cendio 2018-01-12 14:20:53 -------
(In reply to comment #4)
> I can't reproduce the original problem with rdesktop from 4.5.0, 4.7.0 and
> 4.8.0 (and obviously not 4.8.0post). Connecting to the Windows Server 2012 lab
> environment.

As in the server supports 24-bit color? I believe this bug report was based on
the assumption that a server could support 32-bit but not 24-bit color. I
believe that this could very well be a bad assumption though.
------- Comment #6 From cendio 2018-01-15 14:15:20 -------
To some extent, this problem is still unsolved and probably unsolvable. Running
"rdesktop -a 16 ..." will still give you banding artifacts in gradients. We
need to control the server side to be able to introduce dithering or other
techniques to combat the banding.
------- Comment #7 From cendio 2018-01-30 09:42:53 -------
I just got this message when connecting to our Windows 2012R2 cluster:

> Remote desktop does not support colour depth 24; falling back to 32

So it appears that there ARE systems that support 32- but not 24-bit color.
This means that we're not falling back to 16-bit color if there are better
alternatives present. The banding still occurs at 16-bit but that's acceptable.

I haven't yet seen any problems with running 32-bit colors so the color
conversion routines seem to work as expected. I'm considering this bug tested.
------- Comment #8 From cendio 2018-02-23 10:05:51 -------
Forgot release notes.