www.cendio.com
Bug 5760 - Scrolling in using a trackpad is too sensitive
: Scrolling in using a trackpad is too sensitive
Status: CLOSED FIXED
: ThinLinc
Web Access
: trunk
: All All
: P2 Normal
: 4.11.0
Assigned To:
:
:
: 7365
:
  Show dependency treegraph
 
Reported: 2015-12-18 15:42 by
Modified: 2019-10-23 15:08 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-12-18 15:42:54
We have had a report that scrolling is too sensitive in the HTML5 with a
trackpad on Mac OS X. Scrolling with a normal mouse scrool-wheel also seems a
bit too sensitive.

Could perhaps be related to Mac having a different resolution on the trackpad
which we aren't handling properly.
------- Comment #2 From cendio 2015-12-22 16:11:23 -------
(In reply to comment #0)
> Scrolling with a normal mouse scrool-wheel also seems a bit too sensitive.

Disregard this, I have verified that this is not the case.

The issue with a trackpad remains unverified though. A trackpad from Apple will
be ordered.
------- Comment #3 From cendio 2016-02-05 13:31:19 -------
I have reproduced the problem with the Apple Magic Trackpad using the HTML5
client running in Google Chrome and Safari on OSX 10.11.

Scrolling with the trackpad is extremely sensitive, it feels like maybe 10
times as sensitive in the HTML5 client compared to locally.

However, I can't reproduce the problem running the HTML5 client in Firefox on
OSX 10.11.
------- Comment #4 From cendio 2016-02-05 13:39:45 -------
Upstream report:

https://github.com/kanaka/noVNC/issues/577
------- Comment #5 From cendio 2016-11-29 13:51:49 -------
Also seems to happen on Chromebook
------- Comment #6 From cendio 2016-12-01 13:47:38 -------
(In reply to comment #5)
> Also seems to happen on Chromebook

Using the built-in touchpad that is.
------- Comment #7 From cendio 2017-09-12 15:47:07 -------
Scrolling using the trackpad is way to sensitive on my laptop when running
Windows as well. No problem in Linux on my laptop however.

This issue is not limited to Web Access. It stems from the nature of the RFB
protocol where mouse wheel events are sent as clicks with a mouse up followed
by a mouse down. The protocol does not have support for wheel delta or speed.

Currently both client implementations (TigerVNC's vncviewer and noVNC) send one
mouse wheel event to the server for each wheel event no matter how small the
wheel delta is. Trackpads seem to have a tendency for sending a lot of small
delta events (delta ~= 0.01-1) while a regular mouse sends fewer larger delta
events (delta ~= 4-60). VNC usage is only suitable for the latter case really.

One way to mitigate the problem with trackpads is to accumulate a number of
small delta events in the client before sending an event to the server. A
proposed patch that does just this for noVNC can be found here:

https://github.com/novnc/noVNC/pull/896
------- Comment #8 From cendio 2019-10-08 11:03:00 -------
Fixed in noVNC now. Will be resolved once we do a vendor drop.
------- Comment #9 From cendio 2019-10-22 16:55:27 -------
This has now been implemented and works fine.

Works for MacOS when using trackpad on:
 ✓ Safari 13
 ✓ Chrome 77
 ✓ Firefox 69

Works fine on Linux laptop on:
 ✓ Firefox 69

Works on Windows 10 on:
 ✓ Edge 18
 ✓ Firefox 66

As for Chromebook, the scroll doesn't work on Firefox for Chromebook. See Bug
7405 for more information regarding this.
------- Comment #12 From cendio 2019-10-23 15:07:53 -------
Verified that the problem existed on other platforms than just Windows 10 and
macOS. Tested with apple magic trackpad on Fedora - Firefox 69.

So this issue is with high precision trackpads seemingly unrelated to OS, but
the upstream fix solves this.