www.cendio.com
Bug 5806 - tl-crltool can fail to parse CRL list
: tl-crltool can fail to parse CRL list
Status: CLOSED FIXED
: ThinLinc
Misc
: pre-1.0
: PC Unknown
: P2 Normal
: 4.6.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2016-02-24 15:30 by
Modified: 2016-11-17 14:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2016-02-24 15:30:52
We introduced a bug in r22192 that can make tl-crltool error out with "ERROR:
Could not get revocation list size (error code -22)". It depends on the stack
contents if the function will fail or not.

The problem is that we forgot to remove a check for the "count" variable when
it was removed as a parameter.
------- Comment #2 From cendio 2016-02-24 15:39:44 -------
To test, download a few CRL:s and run the tl-crltool --list on them. You can
find CRL URIs in most certificates.
------- Comment #3 From cendio 2016-02-29 16:48:31 -------
Verified using thinlinc build 5045:

  curl http://crl3.digicert.com/sha2-ha-server-g5.crl |
/opt/thinlinc/libexec/tl-crltool --list

Works as expected, verified that same crl failed using tl-crltool from 4.5.0.