www.cendio.com
Bug 6040 - Upgrade libtasn1 to latest version
: Upgrade libtasn1 to latest version
Status: CLOSED FIXED
: ThinLinc
Build system
: trunk
: PC Unknown
: P2 Normal
: 4.8.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2016-10-05 10:03 by
Modified: 2017-03-24 10:50 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2016-10-05 10:03:45
libtasn1: using 4.8, latest is 4.9:

https://ftp.gnu.org/gnu/libtasn1/?C=M;O=D
------- Comment #2 From cendio 2016-11-10 07:22:59 -------
Build and sync packages to repo update of buildserver.
------- Comment #3 From cendio 2016-11-10 08:47:16 -------
Patch for win32 build sent upstream to mailinglist.
------- Comment #4 From cendio 2016-11-10 14:16:26 -------
i386 build fails with:

g++ -o tlclient.bin -g    -static-libgcc -nodefaultlibs \
    tlclient.a localename.o cert/libcert.a neon/src/libneon.a
xmlrpc++/libXmlRpc.a XmuClientWin.o  \
    -Wl,-Bstatic -lfltk -lfltk_images -lXcursor -lXfixes -lXft -lXrender
-lfontconfig -lexpat -lfreetype -lbz2 -lXrandr -lXinerama -lXext -lnettle -ltre
-lstdc++ -lgcc -lgcc_eh -ltasn1 -lpng  -lXxf86misc \
    -Wl,-Bdynamic   -lX11  -lz -lc -lm -ldl
/usr/lib/gcc/i686-pc-linux-gnu/5.1.0/../../../libtasn1.a(parser_aux.o): In
function `_asn1_ltostr':
/home/hean01/Development/cenbuild/repo/rpmbuild/BUILD/libtasn1-4.9/lib/parser_aux.c:570:
undefined reference to `__divdi3'
collect2: error: ld returned 1 exit status
make: *** [tlclient.bin] Error 1
------- Comment #7 From cendio 2016-11-21 12:58:10 -------
Added autotests for all API calls.
------- Comment #11 From cendio 2016-11-24 11:59:13 -------
Build of tests fails when building tlmisc RPM from source tarball. Looks like
test data is not included in source tarball.
------- Comment #14 From cendio 2016-11-28 12:53:12 -------
tl-certtool and friends aren't properly linked after these changes.