www.cendio.com
Bug 6085 - Incorrect initial size for Web Access
: Incorrect initial size for Web Access
Status: CLOSED FIXED
: ThinLinc
Web Access
: trunk
: All All
: P2 Normal
: 4.8.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2016-11-03 11:09 by
Modified: 2017-04-20 11:00 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2016-11-03 11:09:13
After the work done in bug 5845 the initial size for a new session started via
the HTML5 client is incorrect. Since the old control bar stole a part of the
browser window we remove the height of the control bar when calculating the
initial size.
------- Comment #1 From cendio 2016-11-03 11:11:54 -------
The effect of this can easily be seen by starting a new session using the HTML5
client. At the bottom of the browser window you will for half a second see a
white area 41 pixels high.

Note that this initial size calculation is not used for reconnects to an
existing session.
------- Comment #3 From cendio 2016-11-07 07:41:06 -------
Verified that i could reproduce the problem with 4.7.0, which is show at
initial connect. Installing build ThinLinc build 5284 and there are no defect
with screen size upon connect.