www.cendio.com
Bug 6106 - different versions of the client aren't grouped on Windows
: different versions of the client aren't grouped on Windows
Status: CLOSED FIXED
: ThinLinc
Client
: 1.3.1
: PC Unknown
: P2 Normal
: 4.8.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2016-12-07 11:15 by
Modified: 2017-03-24 16:25 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2016-12-07 11:15:36
If you install a new version of the ThinLinc client, or run several versions at
once, then Windows isn't grouping them properly on the task bar. This is very
annoying as it takes up extra space, and you have to keep fixing the pinning.

The problem is that we include the version number in our ID, which we probably
shouldn't. This is what Microsoft says:

> An application must provide its AppUserModelID in the following form. It can
> have no more than 128 characters and cannot contain spaces. Each section should
> be camel-cased.
> 
> CompanyName.ProductName.SubProduct.VersionInformation
> 
> CompanyName and ProductName should always be used, while the SubProduct and
> VersionInformation portions are optional and depend on the application's
> requirements. SubProduct allows a main application that consists of several
> subapplications to provide a separate taskbar button for each subapplication
> and its associated windows. VersionInformation allows two versions of an
> application to coexist while being seen as discrete entities. If an application
> is not intended to be used in that way, the VersionInformation should be
> omitted so that an upgraded version can use the same AppUserModelID as the
> version that it replaced.

Two versions of the client aren't really "discrete entities" like e.g. two
versions of Java, so we really should group things.
------- Comment #2 From cendio 2016-12-08 10:54:39 -------
Checked that the nightly build and a custom build were properly grouped.
------- Comment #3 From cendio 2016-12-08 14:14:03 -------
(In reply to comment #2)
> Checked that the nightly build and a custom build were properly grouped.

Tested on Windows 10.

Confirming that builds prior to r31938 are grouped based on the version number,
and that any builds after r31938 are grouped regardless of version number.

Nice!