www.cendio.com
Bug 7011 - GNOME flashback doesn't start on Ubuntu 16.04
: GNOME flashback doesn't start on Ubuntu 16.04
Status: CLOSED FIXED
: ThinLinc
Desktop environment
: 1.3.1
: PC Unknown
: P2 Normal
: 4.9.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2017-07-13 14:03 by
Modified: 2017-08-24 10:52 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2017-07-13 14:03:10
GNOME flashback simply hangs when selected as a profile on Ubuntu 16.04. All
the users sees is the blue background from the startup.

To test do "sudo apt install gnome-session-flashback" and add this ThinLinc
profile:

> [/profiles/gnome-flashback]
> xdg_session=gnome-flashback-metacity
------- Comment #2 From cendio 2017-07-13 14:27:45 -------
Argh. gnome-flashback has special handling in Ubuntu's weird upstart
redirection voodoo. We need to update tl-run-profile to do the same thing.
------- Comment #5 From cendio 2017-08-10 13:52:51 -------
(In reply to comment #0)
> GNOME flashback simply hangs when selected as a profile on Ubuntu 16.04. All
> the users sees is the blue background from the startup.
> 
> To test do "sudo apt install gnome-session-flashback" and add this ThinLinc
> profile:
> 
> > [/profiles/gnome-flashback]
> > xdg_session=gnome-flashback-metacity

I can't reproduce this on a Ubuntu 16.04.3 with ThinLinc 4.8.0. Need more info
to test this.
------- Comment #6 From cendio 2017-08-14 10:25:56 -------
> 
> I can't reproduce this on a Ubuntu 16.04.3 with ThinLinc 4.8.0. Need more info
> to test this.

The system originally used was running 16.04.2.

upstart = 1.13.2-0ubuntu21.1
gnome-flashback = 3.18.2-1ubuntu1
------- Comment #7 From cendio 2017-08-24 08:41:44 -------
Re-verified that that the problem exists on Ubuntu 16.04.2 LTS installation
with
ThinLinc 4.8.0, then upgraded to to Ubuntu 16.04.3 and the problem is still
there.

The upstart / flashback versions before and after upgade is the same:

  # dpkg -l upstart gnome-session-flashback gnome-flashback
  Desired=Unknown/Install/Remove/Purge/Hold
  | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-
pend
  |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
  ||/ Name                    Version          Architecture     Description
 
+++-=======================-================-================-====================================================
  ii  gnome-flashback         3.18.2-1ubuntu1  amd64            GNOME Flashback
application
  ii  gnome-session-flashback 1:3.18.2-1ubuntu all              GNOME Session
Manager - GNOME Flashback session
  ii  upstart                 1.13.2-0ubuntu21 amd64            event-based
init daemon - essential binaries
------- Comment #8 From cendio 2017-08-24 10:39:44 -------
Updated ThinLinc to build 5543 and verified that flashback session works as
expected.