www.cendio.com
Bug 7058 - incorrect mouse cursor when client is using wayland
: incorrect mouse cursor when client is using wayland
Status: CLOSED WONTFIX
: ThinLinc
| rdesktop (deprecated)
: 1.3.1
: PC Unknown
: P2 Normal
: 4.9.0
Assigned To:
:
:
:
: 5646
  Show dependency treegraph
 
Reported: 2017-09-27 13:59 by
Modified: 2017-10-03 13:11 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2017-09-27 13:59:51
When the Linux client is on a Wayland system we sometimes get a bad mouse
cursor. We've seen it with the standard I-beam cursor on Windows, but there
might be others.

Instead of the correct cursor we get two thick vertical bars, not unlike a
pause symbol. It doesn't seem to be a simple inverted version of the I-beam
though as there isn't any pixels at the top and bottom.

The cursor starts working if any pixel is changed from alpha having 00 or ff,
so there seems to be some heuristic somewhere that detects simple cursors like
this.
------- Comment #1 From cendio 2017-09-27 16:33:55 -------
I can reproduce the same bug in Firefox using the same cursor. Not quite known
why rdesktop is unaffected under the same circumstances.
------- Comment #2 From cendio 2017-09-27 16:36:53 -------
Seems to be related to the size. rdesktop has a lot of padding around the
cursor, expanding it to 32x32 pixels. Doing the same in Firefox gets a working
cursor.
------- Comment #3 From cendio 2017-09-27 17:15:26 -------
Found the bug in Xwayland:

https://bugs.freedesktop.org/show_bug.cgi?id=103012

So either we ignore it until they've fixed it, or we do a workaround (e.g. pad
to 8 pixels wide).
------- Comment #4 From cendio 2017-10-03 13:11:34 -------
We trust that upstream will roll out the patch they have suggested on the
upstream bug entry.