www.cendio.com
Bug 5571 - Xvnc crash when a window is maximized using KDE
: Xvnc crash when a window is maximized using KDE
Status: CLOSED FIXED
: ThinLinc
VNC
: 4.2.0
: PC Unknown
: P2 Normal
: 4.5.0
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2015-06-17 09:30 by
Modified: 2015-09-25 14:00 (History)
Acceptance Criteria:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From cendio 2015-06-17 09:30:01
Program received signal SIGFPE, Arithmetic exception.
0x00000000005ff6af in rfb::Region::get_rects (this=0xab8218, rects=<optimized
out>, left2right=<optimized out>, 
    topdown=<optimized out>, maxArea=0) at
/usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/Region.cxx:210
210          int h = maxArea / (xrgn->rects[i].x2 - xrgn->rects[i].x1);
(gdb) bt
#0  0x00000000005ff6af in rfb::Region::get_rects (this=0xab8218,
rects=<optimized out>, left2right=<optimized out>, 
    topdown=<optimized out>, maxArea=0) at
/usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/Region.cxx:210
#1  0x0000000000603bd6 in rfb::ComparingUpdateTracker::compare (this=0xab8210)
    at
/usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/ComparingUpdateTracker.cxx:69
#2  0x0000000000601661 in rfb::VNCServerST::checkUpdate (this=0xab7ea0)
    at
/usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/VNCServerST.cxx:617
#3  0x000000000060f4a0 in rfb::VNCSConnectionST::writeFramebufferUpdate
(this=0xed8b20)
    at
/usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/VNCSConnectionST.cxx:973
#4  0x00000000006101c9 in rfb::VNCSConnectionST::writeFramebufferUpdateOrClose
(this=0xed8b20)
    at
/usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/VNCSConnectionST.cxx:248
#5  0x00000000006008af in tryUpdate (this=0xab7ea0)
    at
/usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/VNCServerST.cxx:565
#6  rfb::VNCServerST::tryUpdate (this=0xab7ea0)
    at
/usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/VNCServerST.cxx:553
#7  0x0000000000600915 in rfb::VNCServerST::handleTimeout (this=<optimized
out>, t=<optimized out>)
    at
/usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/VNCServerST.cxx:492
#8  0x000000000060d8b6 in rfb::Timer::checkTimeouts ()
    at /usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/Timer.cxx:104
#9  0x000000000060017e in rfb::VNCServerST::checkTimeouts (this=0xab7ea0)
    at
/usr/src/debug/thinlinc-vnc-server/tigervnc/common/rfb/VNCServerST.cxx:184
#10 0x00000000005f09e1 in XserverDesktop::readWakeupHandler (this=0xab7820,
fds=0xa9f720 <LastSelectMask>, 
    nfds=<optimized out>) at XserverDesktop.cc:517
#11 0x00000000005e69fa in vncCallReadWakeupHandlers (fds=0xa9f720
<LastSelectMask>, nfds=1) at vncExtInit.cc:228
#12 0x00000000005ee25c in vncWakeupHandler (data=<optimized out>,
nfds=<optimized out>, readmask=<optimized out>)
    at vncBlockHandler.c:67
#13 0x000000000057b09b in WakeupHandler (result=1, pReadmask=0xa9f720
<LastSelectMask>) at dixutils.c:423
#14 0x00000000005d1942 in WaitForSomething (pClientsReady=0xec5e40) at
WaitFor.c:240
#15 0x0000000000576622 in Dispatch () at dispatch.c:361
#16 0x000000000045adea in main (argc=<optimized out>, argv=0x7ffd8b893398,
envp=<optimized out>) at main.c:295
------- Comment #1 From cendio 2015-06-17 09:39:36 -------
This is not reproduciable on a RHEL7 with KDE 4.10.8
------- Comment #2 From cendio 2015-06-17 09:41:17 -------
Issue is reproducable on SLED 11 SP3 with KDE 4.3.5.

To reproduce the crash just start a Konsole and maximize the window.
------- Comment #3 From cendio 2015-07-09 10:02:50 -------
We've got reports of this happening with KDE on CentOS 6 as well.
------- Comment #4 From cendio 2015-09-08 13:04:41 -------
*** Bug 5628 has been marked as a duplicate of this bug. ***
------- Comment #5 From cendio 2015-09-08 13:21:46 -------
Upstream bug report:

https://github.com/TigerVNC/tigervnc/issues/185
------- Comment #7 From cendio 2015-09-17 12:57:56 -------
Verified that I could reproduce the Xvnc crash using build 4854 and that
upgrading to build 4889 resolves this issue.

Works as expected.